Skip to content
Back to search

CVE-2026-111497

CRITICAL
9.8 CISA KEVNVD

Summary

generated automatically from NVD data

CVE-2026-111497 is a buffer overflow in the Brotli decoder (c/dec/decode.c) in Google Brotli 1.0.3 through 1.2.0. A crafted Brotli-compressed stream sent by a remote unauthenticated attacker can corrupt adjacent decoder state memory, leak memory contents, cause denial of service, or potentially allow arbitrary code execution. It is listed in the CISA KEV catalog and carries a CVSS v3.1 score of 9.8 (CRITICAL); the description advises updating to 1.0.10, 1.1.1 or 1.2.1.

NVD description

A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream. Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.

Share:

⚠️ Actively exploited — CISA KEV

This CVE was added to CISA's Known Exploited Vulnerabilities catalog on 2026-10-27. It is confirmed exploited in the wild and must be patched as a priority.

Remediation deadline (US federal agencies): 2026-11-10

EPSS · FIRST.org

55.5%probability of exploitation in the next 30 days

Higher than 99% of scored CVEs

EPSS (Exploit Prediction Scoring System) estimates, from observed exploitation activity, how likely a CVE is to be exploited in the next 30 days. It complements CVSS, which measures severity, not likelihood. Score of 2026-10-27, recomputed daily by FIRST.org.

In-depth analysis on cveo.tech

This CVE is covered in an article: context, affected versions and published fixes.

CVSS v3.1 Score

9.8
/ 10.0
CRITICAL
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Information

Published
22 oct. 2026
Updated
28 oct. 2026
Status
Analyzed
Source
cve-coordination@google.com

Affected products

google brotli
Versions ≥ 1.0.3, < 1.0.10 · ≥ 1.1.0, < 1.1.1 · ≥ 1.2.0, < 1.2.1
nodejs node.jsAll Node.js CVEs →
Versions < 22.23.4 · ≥ 23.0.0, < 24.22.1 · ≥ 25.0.0, < 26.12.1
python-hyper brotlicffi
Versions < 1.2.1.0
microsoft .net
Versions ≥ 8.0.0, < 8.0.33 · ≥ 9.0.0, < 9.0.22 · ≥ 10.0.0, < 10.0.14 · 11.0.0
debian debian linux
Versions 12.0
istio istio
Versions < 1.29.9 · ≥ 1.30.0, < 1.30.6 · ≥ 1.31.0, < 1.31.2
anthropic bun
Versions < 1.4.4
envoyproxy envoy
Versions < 1.37.8 · ≥ 1.38.0, < 1.38.6 · ≥ 1.39.0, < 1.39.3

Bounds published by NVD: "< 8.4.27" means 8.4.27 is no longer vulnerable. The fixed release to install is in the vendor advisory.

Weaknesses (CWE)

CWE-252CWE-787

Similar CVEs

Other vulnerabilities of type CWE-252

…

Know which CVEs hit the versions you run.

Add the product and its version: cveo.tech lists the CVEs that affect it right away, then alerts you by email when a new one affects it — including before NVD has finished its analysis. Free, an account is all it takes.